网络安装帮助
角落 | 角落

此帮助是专为可在有线或无线网络上安装的 HP 设备提供的。在安装期间，通过单击帮助，可从以下屏幕获得帮助。相关主题提供了进一步的背景知识。

• 连接类型
• 网络设置 — 建立与打印机的连接
• 打印机网络连接
• 无线网络设置 — 打印机网络连接
• 查找网络打印机
• 无线网络设置 — 打印机设置菜单向导
• 打印机设置选项


连接类型

选择要将 HP 打印机连接到计算机的方式。设置屏幕将列出可用于您的设备的选项。

您的情况

您的打印机功能

设置要求

您的连接选项

• 您不需要与其他 PC 共享打印机
• 或者您没有局域网 (LAN)
• 或者您的 PC 没有连接到网络
• 或者您有网络，但不想现在将打印机连接到网络

您的打印机具有网络连接功能，但是您不想现在将其连接到网络

在安装软件提示时连接 USB 电缆

USB

直接在您的 PC 和打印机之间连接 USB 是最简单快捷和最可靠的安装。但是，USB 连接会限制其他 PC 对打印机的访问。

• 您拥有一个具备以太网（有线 — 802.3）连接的局域网 (LAN)
• 或者您拥有一个具备无线路由器/访问点（其中有一个可用的以太网/802.3 端口）的 LAN。另外，您的打印机距离要通过电缆连接的无线路由器/访问点很近。

您的打印机具备以太网（有线 — 802.3）网络连接功能

• 局域网 (LAN)
• 用于将打印机连接到网络的以太网电缆（5 类）

以太网（有线 — 802.3）网络

有线网络连接快速可靠。同一网络上的其他 PC 可通过该连接使用打印机。

• 您的 PC 已连接到无线 802.11 网络，并且您希望该网络上的其他 PC 可以访问打印机
• 您希望具有可在远离无线路由器/访问点的位置安放打印机的灵活性

您的打印机具备无线网络 (802.11) 连接功能

• 具备无线路由器/访问点的无线 802.11 局域网 (LAN)
• SSID（无线网络名称）
• 密码（用于加密网络）
• USB 电缆，如果适用于您的打印机（无线 USB 设置）
• 有关详细信息，请参阅无线网络连接 (802.11)。

无线 (802.11) 网络

通过无线网络连接，您可以不受电缆的限制安放打印机。此网络上的其他 PC 可通过该连接访问打印机。但是，与其他类型的连接相比，设置该连接的时间较长。


无线网络连接 (802.11)

注意 无线通信标准是 802.11 标准，而非 Bluetooth。

基础设施无线网络连接

通过基础设施无线网络连接（802.11 标准），多台计算机可以访问同一台打印机（如果这些计算机均已连接到网络且针对该打印机设备进行了设置）。基础设施无线网络由无线路由器/访问点创建，其收发信号的方式类似于无绳电话基站的工作方式。计算机和设备需要位于信号覆盖范围内，才能连接到该网络。但是，这也意味着，您的路由器范围内可能存在多个无线路由器。

要通过基础设施无线网络将计算机连接到打印机，您需要：

• 已设置的无线路由器/访问点。
• 由路由器创建的名为 SSID（服务设置标识符）的网络名称。在设置无线网络时，路由器将得到一个默认的 SSID（通常为路由器制造商的名称），但是理想的情况是将 SSID 更改为更容易识别的人的姓名。如果不这样做，您可能最后会得到与邻居网络名称相同的网络。这将对选择正确的网络带来不便，也会对网络安全造成危害。通常，您的打印机将显示所有检测到的网络的名称。请确保选择您自己的网络。
• 您的无线网络的安全设置。大多数无线网络使用密码加密，每个设备都需要知道该密码才能进行连接。这可用于阻止不受欢迎的外部人员访问您的无线网络。最常用的加密类型是 WEP 和 WPA。如果您的无线网络使用其中一种加密，系统可能会要求您输入密钥或密码，具体取决于加密类型。WEP 密钥或 WPA 密码区分大小写：使用原始定义的精确大小写字母输入密钥或密码。您可以通过转至 www.hp.com/go/networksetup 下载应用程序以帮助查找这些设置。（此应用程序仅适用于 Windows Internet Explorer 英文版。）如果您的网络没有启用安全保护，那么您只需要输入网络名称。

临时无线网络连接

您也可以将计算机直接连接到 HP 设备，而无需路由器或访问点。这种方式称为“临时”无线网络连接。HP 打印机出厂时就预配置了临时网络连接。

如果您之前使用基础设施连接设置了打印机（即使用无线路由器/访问点），但现在希望设置一个临时连接，则可以使用打印机控制面板上的显示菜单中的恢复网络默认设置（如果可用）。


网络设置 — 建立与打印机的连接

“网络设置”屏幕会告诉您现在应该使用以太网电缆将打印机连接到路由器。

图：显示以太网接口（接口编号 1 号和接口编号 2 号分别位于电缆两端）的图表。

图：编号 1 | 将以太网（5 类或 RJ45）电缆的一端连接到有线路由器上的 LAN 端口。检查路由器是否已打开且已连接到网络。
图：编号 2 | 将电缆的另一端连接到打印机背面的以太网/802.3 端口。（通常，在运输设备时，此端口中将有一个黄色插块。）您需要安装打印机，然后开启打印机。连接完成后几秒钟内，端口周围的黄色和绿色指示灯应亮起并闪烁。
 | 或者选择继续安装，现在不连接打印机，我将在以后连接。


打印机网络连接

“打印机网络连接”屏幕会询问您是否已在无线网络上设置了打印机。

• 如果您知道打印机已连接到网络，请单击是。例如，您可能通过打印机的控制面板显示屏使用过无线设置向导，或知道网络上的其他人已经在使用打印机。
• 如果没有连接打印机或不知道是否已连接打印机，请单击否。

要检查连接的详细信息，请打印网络配置页或无线网络测试报告。

单击下一步继续安装。


网络配置页或无线网络测试报告

网络配置页是打印机技术规格的报告，例如，网络状态、活动连接类型、序列号、硬件地址（MAC 地址）、网络名称 (SSID)、验证类型和 IP 地址。在设置或解决 HP 打印机的网络连接问题时，获取打印副本很方便。

如果已将打印机连接到无线网络，请打印无线网络测试报告。这份报告包括诊断消息以及连接的详细信息。

• 要使用控制面板上的显示屏为打印机打印网络配置页或无线网络测试报告，请按“设置”按钮。然后，浏览报告的菜单（例如，在网络设置或打印报告下查找）并将其选中。
• 对于大多数没有显示屏的 HP 打印机，您可以通过按住恢复按钮两秒钟来打印网络配置页。同时还将打印“无线网络测试报告”。有关详细信息，请参阅打印机文档。

要检查 HP 打印机的当前连接状态及连接到的网络，请查看：

• 网络状态以确定打印机是否已就绪，即是否已连接到网络。
• 网络名称 (SSID) 以确定这是否为您的网络的名称。但是，如果这是无线路由器（或访问点）的默认名称，您邻居的网络也可能拥有同样的名称。
• IP 地址，因为您需要使用此地址执行高级搜索。


无线网络设置 — 打印机网络连接

“无线网络设置”屏幕为您推荐了一些可用的疑难排解步骤，有助于在无线网络上查找您的打印机。

情形

对策

备注

确保您的打印机和无线路由器/访问点已开启

检查：

• 无线路由器/访问点和打印机是否可运行
• 计算机是否已连接到网络

有关如何检查操作是否正确的详细信息，请参阅路由器文档。

移动计算机和打印机以靠近无线路由器。
• 安装期间，最好让打印机和 PC 靠近无线路由器/访问点
• 如果要在安装后移动打印机，请确定打印机已打开且信号仍然很强

有关连接范围和最佳连接条件的详细信息，请参阅路由器文档。

打印无线网络测试报告

仔细阅读任何诊断消息

确保您的 PC 已连接到网络

检查：

• 您的网络是否正常，方法是确认您的 PC 是否连接到 Internet
• 您的 PC 是否已连接到网络，方法是确认网络名称是否正确
• 您的网络信号是否足够强且状态是否已就绪


查找网络打印机

浏览打印机列表以查看您正在安装的打印机是否在列表中。

• 如果您的打印机被列出一次，请在列表上选择该打印机名称，然后单击下一步继续。
• 如果您的打印机未列出（或被列出多次），请打印网络配置页或无线网络测试报告以用于疑难排解。

疑难排解

1 浏览下表并检查适用于您的情形的项目。
2 在进行调整或纠正后，单击刷新列表。如果您的打印机当前显示在列表上，请选择该打印机，然后单击下一步继续。
3 如果您的打印机不在列表中，请选择我的打印机未列出。然后选择显示高级搜索选项。输入打印机的 IP 地址以作为无线连接的搜索标准（包括数字之间的点号），然后单击搜索。如果您的打印机当前显示在列表上，请选择该打印机，然后单击下一步继续。
4 如果在执行“高级搜索”之后，您的打印机仍未出现，请选择我的打印机未列出，然后单击下一步以继续。

情形

可能的原因

检查：

我的打印机未列出

• 由于网络十分复杂，您只能通过按 IP 地址搜索的方式查找您的打印机。
• 或者计算机上的安全软件（防火墙、防病毒软件、反间谍软件）可能会阻止计算机和 HP 设备之间的通信。
• 或者您的计算机已连接到虚拟专用网络 (VPN)。
• 或者您的路由器启用了 MAC 过滤。
• 或者您的 PC 已连接到与打印机不同的网络。
• 或者您的打印机未连接到您自己的网络。它可能已连接到具有相同名称的邻居的网络上。
• 您的计算机已连接到网络
• 您的 Internet 连接已激活，显示网络处于可运行状态
• 正在向您的打印机通电
• 您的以太网线已正确连接（有线）
• 路由器已打开且正在传输数据（无线）
• 安全软件没有阻止通信
• 当您要通过网络访问打印机时与 VPN 断开连接。
• 您的路由器已禁用了 MAC 过滤或已将打印机添加到路由器的 MAC 地址过滤列表中。

列出了多台打印机

您的邻居或同事中有人在网络上安装了同一型号的打印机。

• IP 地址与所需连接的报告上的地址相匹配
• 序列号是您的打印机的序列号
• MAC 地址与所需连接的报告上的地址相匹配


序列号

印刷在 HP 设备背面或底部标签上以及网络配置页或无线网络测试报告上的一长串数字。


IP 地址

Internet 协议地址，这是一个由网络分配给已连接设备的数字标识符。您可以查找无线和有线连接的 IP 地址，方法是在设备的控制面板上选择“设置”（扳手）按钮，然后浏览显示屏上的设置（如果适用于您的打印机）。您也可以在网络配置页或无线网络测试报告上找到 IP 地址。

有效的 IP 地址包含四个由点号分隔的数字，例如，192.168.1.001。（但是，像 0.0.0.0 这样的 IP 地址是无效的。）


MAC 地址

硬件地址（或媒体访问控制地址）是在制造期间由 HP 分配给网络板的标识符。MAC 地址印刷在序列号标签及网络配置页上。


显示高级搜索选项

如果您的打印机仍没有显示在列表上，请选择显示高级搜索选项。

1 可通过按下控制面板上的“设置”（扳手）按钮和浏览 IP 地址，查找打印机的 IP 地址。或者打印网络配置页或无线网络测试报告。
2 在搜索字段中输入打印机的 IP 地址，然后单击搜索。
3 搜索之后，单击刷新列表，看看现在是否已找到您的打印机。如果已找到，请在列表中单击您的打印机。
4 单击下一步。


路由器已打开且正在传输数据

请检查您的无线路由器/访问点是否已开启且可运行。例如，您可能想要检查网络上现有的计算机是否可连接到 Internet。

再次执行搜索前，重置网络可能有所帮助。

1 关闭调制解调器和路由器。
2 再次打开调制解调器。等待其完全启动。
3 再次打开路由器。待其完全启动后，尝试再次搜索您的打印机。


安全软件

请检查计算机上的安全软件没有阻止此连接。

1 暂时禁用安全软件，然后在此屏幕上单击刷新列表或执行高级搜索。
2 如果您的打印机当前显示在列表上，请重新启用安全软件。您需要将安全软件配置为允许 UDP 端口 427 打开。然后在此屏幕上单击刷新列表或执行高级搜索。
3 如果您的打印机仍未出现在列表中，请选择我的打印机未列出，然后单击下一步继续。


无线网络设置 — 打印机设置菜单向导

如果您的打印机具备带菜单的显示屏，则可以使用控制面板中的无线设置向导。

使用无线设置向导
1 按下控制面板上的“设置”（扳手）按钮，然后从显示的菜单中浏览无线设置向导。
2 按照显示屏上显示的说明进行操作，根据请求输入信息。有关无线设置向导的详细信息，请参阅 HP 打印机的文档。此文档可能位于印刷版指南、CD 上的软件指南中，或可通过 HP 解决方案中心（如果已安装）获得。
3 选择无线网络测试以打印报告。该报告可确认连接并提供一份详细信息的记录。浏览菜单以查找该选项（通常位于“打印报告”或“网络设置”下）。
4 在完成向导且打印机已加入无线网络后，单击下一步继续。


打印机设置选项

在网络上设置打印机时会不断出现问题。您将需要选择某个选项以表明您要继续的方式。以下部分将介绍了选择每个选项的详细信息和好处。

• 改为通过 USB 安装打印机。我可以在以后重试网络安装
• 继续安装，但不连接打印机。我将在以后连接
• 继续网络安装并忽略诊断到的错误

在继续设置连接前，您可能想要查看在继续网络连接之前进行疑难排解，其中包括无线和有线网络设置中要采取的步骤。

准备就绪后，您可以执行以下操作之一以重试安装：

• 转至开始菜单/所有程序/HP/（您的 HP 设备名称）/添加设备以重新启动安装进程。
• 插入 HP 设备附带的软件 CD 以显示菜单。选择添加设备（如果可用于设备）以重新启动安装进程。
• 如果可用，使用桌面图标添加设备。

选择某个选项后，下一步按钮将激活。单击下一步继续操作。


改为通过 USB 安装打印机。我可以在以后重试网络安装

选择此选项以通过直接的 USB 连接将您的打印机连接到 PC。

选择某个选项后，下一步按钮将激活。单击下一步继续操作。


继续安装，但不连接打印机，我将在以后连接

选择此选项意味着您当前无法使用 HP 设备。但是，现在通过将 CD 中的软件安装在计算机上，之后您只需从开始菜单中选择添加设备或连接 USB 电缆，即可进行连接。

要重试网络连接，请先检查一些典型的错误原因（请参阅在继续网络连接之前进行疑难排解）。


继续网络安装并忽略诊断到的错误

如果选择此选项，网络安装将继续，但是在安装之后您的打印机可能会遇到问题。您可能要查看在继续网络连接之前进行疑难排解以了解继续安装前要检查的事项。

如果您认为已经解决了阻碍在网络上查找打印机的问题，请选择此选项，然后单击上一步。


在继续网络连接之前进行疑难排解

有关在解决 HP 设备的网络连接问题过程中使用的其他信息，请阅读以下主题：

• 无线网络设置
• 确保您的打印机和无线路由器/访问点已开启
• 移动计算机以靠近打印机
• 检查您的 PC 是否已连接到网络
• 暂时禁用 PC 上的防火墙、反间谍软件或任何安全软件
• 允许访问以下文件
• 允许访问以下端口
• 有线网络


无线网络设置

注意 在可以连接到无线网络之前，您的网络需要能够完全正常工作且打印机已完全设置。

前提条件
• 无线路由器已设置且已开启。
• 网络名称 (SSID)
• 安全设置（密码 — 区分大小写）


确保您的打印机和无线路由器/访问点已开启

检查：

• 打印机是否已接通电源、已开启、无线广播已打开（通常是标记为 802.11 的蓝色指示灯） 。
• 无线路由器/访问点是否已接通电源、已开启且可运行。


移动计算机以靠近打印机

检查：

• 打印机和 PC 是否处于无线路由器/访问点范围内。有关范围和条件的信息，请参阅路由器文档。
• 打印机和 PC 是否已开启。


检查您的 PC 是否已连接到网络

检查：

• 计算机是否已连接到您自己的网络：检查 Windows 网络下网络名称、信号强度及状态。
• 要检查网络是否处于可运行状态，请确定您的计算机是否可访问 Internet。


暂时禁用 PC 上的防火墙、反间谍软件或任何安全软件

安全软件可能会阻止打印机的连接。要了解如何暂时允许 HP 软件建立打印机连接，请参阅安全软件文档。请确保在建立连接后立即启用所有安全软件。


允许访问以下文件

Windows 计算机上的安全软件可能会按逐个文件的方式询问您是否允许 HP 访问某些端口和文件。表明以下 HP 文件应该可信：

• hpqkygrp.exe，位于 C:\program files\HP\digital imaging\bin 中
• hpiscnapp.exe，位于 C:\program files\HP\digital imaging\bin 中
• hpqste08.exe，位于 C:\program files\HP\digital imaging\bin 中
• hpqtra08.exe，位于 C:\program files\HP\digital imaging\bin 中
• hpqthb08.exe，位于 C:\program files\HP\digital imaging\bin 中
注意 并非所有以上列出的文件均被 HP 产品使用。如果某个文件在指定的文件夹中找不到，则无需添加该文件。有关如何配置防火墙端口设置以及如何将 HP 文件添加到“受信任”列表，请参阅防火墙文档。


允许访问以下端口

您的 HP 设备也会使用下列端口，您可能需要在防火墙配置中开放这些端口。

功能

传入 (UDP) 端口

传出 (TCP) 端口

• 传入 (UDP) 端口是计算机上的目标端口。
• 传出 (TCP) 端口是 HP 设备上的目标端口。

137, 138, 161, 427

137, 139, 427, 9100, 9220, 9500

打印

427, 137, 161

9100

照片卡上传

137, 138, 427

139

扫描

427

9220, 9500

HP 设备状态

161

[无]

传真

427

9220

HP 设备安装

427

[无]


有线网络

• 请确保您的打印机和网络路由器已开启且可运行。
• 检查您的 HP 设备是否已安全连接到路由器。

一旦建立连接，以太网/802.3 端口周围的黄色和绿色指示灯将在几秒钟后开始闪烁。